mwm - problem with switching windows

This forum is read only. No new submissions are accepted.

Questions about motif? Contact us

5 posts / 0 new
Last post
mwm - problem with switching windows

Submitted by Sophie on Thu, 07/15/2010 - 15:16.


I have a weird problem with mwm on my laptop, which is running on x86_64 Gentoo Linux with kernel 2.6.33-gentoo-r22, 1.7.6, and OpenMotif 2.3.2-r2. I have no idea if this is a supported configuration or not, so if not, please let me know. (If more details on the environment are needed, I'm happy to give them.)

The problem is that although I can run mwm just fine, trying to switch windows by clicking in the client area of a window in the background results in what seems to be mwm freezing - which is to say, although I can move the mouse pointer on the screen and my X apps continue to update their windows, all input from the mouse and keyboard are swallowed and input events do not make their way to any running X apps. I verified this by running xev and attempting to switch focus to it when it is in the background by clicking in its client area. It receives a single event, LeaveNotify (even though my pointer has not left the window) and further events are not printed to the console. The X session is made unusable until I send a SIGTERM to the mwm process, at which point mwm pops up its "Quit MWM?" box, which I can cancel and suddenly everything works fine again.

If I switch windows by clicking on the title bar of a window in the background, it works just fine; the freezing effect isn't triggered.

I should point out again that the applications continue to *run* and do not show any visible indication that anything is wrong, except that the window doesn't get the focus or come to the top, and all input is ignored. For example, if I'm watching a YouTube video in Firefox in the foreground and I try to click on a window in the background, the freezing effect will occur, but I can still watch and listen to the video; I just can't interact with the controls, or anything else for that matter.

This happens even when my .Xdefaults file is empty, so it doesn't seem like that would be the problem.

Does anybody have any ideas? I'm stumped. I can do some more tests if anybody needs me to do so.

Thu, 07/15/2010 - 15:42#1

Thu, 07/15/2010 - 15:42#1


I just tried installing

I just tried installing OpenMotif 2.3.3, and the problem persists. :(

(Yes, I did restart the X server.)


Wed, 07/28/2010 - 02:45#2

Wed, 07/28/2010 - 02:45#2


Hello Sophie, Good, I

Hello Sophie,

Good, I thought I was going mad :)

It seems that an update to xorg has caused this freeze bug.

I came in to contact with it here (OpenCDE uses mwm as it's window manager)

The following is the only work around I have come up with...

in your .Xdefaults file add...
Mwm*keyboardFocusPolicy: pointer

Auto focus is sodding annoying, but better than x11 freeze :p

Best Regards,





Mon, 08/30/2010 - 17:37#3


For now I just moved to

For now I just moved to fvwm, although I hope mwm can be fixed. :/ I can't stand auto-focusing.


Fri, 09/17/2010 - 11:20#4

Fri, 09/17/2010 - 11:20#4


The issue is addressed to

The issue is addressed to xserver. Please have a look at