4
ICS Tutorials: Menus and Dialogs

In this tutorial, you will add several pulldown menus and several types of dialogs to the
address book. This will complete the principal elements of the interface.
Note: This tutorial assumes that you have chosen C as your language. The steps will be
somewhat different if you are using ViewKit or Java. Those differences will be discussed
in tutorials seven and eight respectively.

Before You Begin This Tutorial

Start Builder
Xcessory



Make a new directory called tutorial_4 and change directories to
tutorial_4.



If you have not started Builder Xcessory yet, enter the following at the prompt in the
tutorial_4 directory:
% bx

Getting Started

Initialize your application as follows:
1.
2.

Clear the Builder Xcessory display by selecting New from the Main Window File
menu.
Open the UIL file you saved at the end of Tutorial 3:
<tutorial_path>/tutorial_3.uil

Creating a Menu Bar
Before you create the pulldown menus, you must add a Menu Bar to the address book. To
add the Menu Bar, perform the following steps:
1.
2.

Use MB2 to select XmMenuBar from the Motif Menus group of the Palette.
Drag the XmMenuBar to the Browser and drop it onto the mainWindow node in
the tree. Builder Xcessory automatically places the menu bar across the top of the
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mainWindow. The XmMenuBar will be empty because you have not added any
menus to it yet! Well do that next.

You will now add three pulldown menus to the address book: File, Edit, and Help.
To create the File menu, perform the following steps:

Adding a
PulldownMenu

1.

With MB2, select the XmPulldownMenu from the Palette and drop it onto the Menu
Bar in the interface.

Note: When you create a PulldownMenu, Builder Xcessory actually creates 3 widget
instances: a CascadeButton, with an associated PulldownMenu, which parents a
PushButton. This hierarchy is reflected in the Browser.
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2.

4

If you have set the Auto Menu Popup toggle in the User Preference, the menu
initially appears posted (i.e., popped-up). To unpost the menu, unset Show Menu
Children in the Main Window View menu or press Ctrl/U, the keyboard accelerator
for that menu item.

To change this default behavior, unset the Auto Menu Popup toggle in the Behavior tab
of the User Preferences dialog. The User Preferences dialog is accessed via the Options
menu choice in the Main Window.
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Adding Menu Items
Now you will add two more PushButtons and a Separator to the File menu. Perform the
following steps:
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1.
2.
3.

Select cascadeButton by clicking MB1 on the node in the Browser.
If pulldownMenu is not already posted, post it by pressing Ctrl/U.
Use MB2 to drag an XmPushButton to the pulldownMenu on the interface.
Builder Xcessory automatically adds items you place on a menu at the bottom of the
menu.

4.
5.

Add an XmSeparator to the menu.
Add another XmPushButton to the menu.
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Naming Widget
Instances

6.
7.

4

Select cascadeButton in the Browser.
Change the Instance Name to filePane.
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8.

Repeat steps 67 for each of the PushButtons, using the following names:
Object
pushButton
pushButton1
pushButton2

New Name
fileOpen
fileSave
fileExit

Labeling File Menu Components
Now you will use the Resource Editor to add labels, accelerators, and mnemonics to the
File menu. To label the File menu header, perform the following steps:
1.
2.

Select filePane.
Change the following resources, setting each storage location to App:
Resource Value Location
labelString

File

App

mnemonic

F

App

Note: Here and in the following tutorials, set the resource storage location for any
displayed text to App. This will simplify internationalization in the future.
Note: Setting the mnemonic allows you to post the File menu by pressing Alt/F on the
keyboard.
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4.

4

Similarly, set the following resources for fileOpen:
Resource

Value

accelerator

Ctrl<key>O

Location
App

acceleratorText Ctrl+O

App

labelString

Open...

App

mnemonic

O

App

Setting the
accelerator text
for fileOpen

5.

6.

Set the following resources for fileSave:
Resource

Value

accelerator

Ctrl<key>S

Location
App

acceleratorText Ctrl+S

App

labelString

Save

App

mnemonic

S

App

Finally, set the following resources for fileExit:
Resource Value Location
labelString

Exit

App

mnemonic

X

App
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Your interface should now appear like the figure below (remember to save your work in
the tutorial_4 directory before proceeding!)

7.

Select filePane again and hide the menu by pressing Crtl/U

Using Keep Parent
Keep Parent makes it easier to add multiple children to a widget instance, especially
when that widget instance is a menu.
The Edit menu includes six PushButtons and a Separator. To add these elements, use the
steps in the following sections:
1.
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Add an XmPulldownMenu to the interface by dragging it to the menuBar using
MB2. The menu portion of your user interface should look like the image below.
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2.

4

Select the Keep Parent toggle from the Main Window View menu.

Note: Only valid children for the selected object will be sensitive on the Palette.

Adding Menu
Items

3.
4.

On the Browser, select pulldownMenu1.
Add five XmPushButtons. Because Keep Parent is on, you can add items to the
interface simply by clicking on them in the Palette with MB1. Builder Xcessory
knows to parent the new object to the selected object.
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5.
6.
7.

8.
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Add an XmSeparator to the interface. Click on XmSeparator on the Palette.
The Separator is at the bottom of the menu. To move it up to the correct spot,
perform the following steps:
Select separator1 on the Browser tree.
Press Ctrl/R to raise the Separator one level. (Ctrl/L lowers the item one level.)

Perform the raise operation three more times. separator1 should now follow
pushButton1. Your menu should look like the following diagram.
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9.

4

Unset the Keep Parent toggle on the Main Window View menu.

Setting Instance Names for Edit Menu Components
As always, using your own instance names when working with Builder Xcessory is a good
practice. Use the following table to assign new names for each of the objects in the Edit
menu.
Object
cascadeButton
pushButton
pushButton1
pushButton2
pushButton3
pushButton4
pushButton5

New Name
editPane
editNew
editModify
editCut
editCopy
editPaste
editDelete

To change the Instance Name, perform the following steps for each object in the table
above:
1.

Click on the instance name in the Browser to select it For example, click on
cascadeButton in the Browser to select it.
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2.
3.
4.

Then in the Resource Editor window, click on the text cascadeButton to the right
of the label Instance Name
Type the new name.
Click on the check mark at the end of the text field, or press Return.

Note: We set all the new names for the instances at once to avoid confusion. More
commonly, you will assign a new Instance Name as you tailor the other resources of an
object. Well use this more efficient approach in future tutorials.

Setting Resources for the Edit menu Components
Now you will use the Resource Editor to add labels, accelerators, and mnemonics to the
Edit menu. Tailor the Edit menu by performing the following steps:
1.
2.

3.

Select the editPane instance of the cascadeButton in the Browser.
Change the following attributes and resources:
Resource

Value

labelString

Edit

App

mnemonic

E

App

Similarly, set the following attributes for editNew under pulldownMenu1:
Resource
accelerator
acceleratorText

4.

Location
App

Ctrl+N

App

New Entry...

App

mnemonic

N

App

Set the following attributes for editModify under pulldownMenu1:
accelerator
acceleratorText
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Value
Ctrl<key>N

labelString

Resource
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Location

Value

Location

Ctrl<key>M

App

Ctrl+M

App

labelString

Modify Entry...

App

mnemonic

M

App
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5.

4

Set the following attributes for editCut under pulldownMenu1:
Resource

Value

Location

Ctrl<key>X

App

Ctrl+X

App

labelString

Cut

App

mnemonic

t

App

accelerator
acceleratorText

Note: C is not available here, because mnemonics must be unique within a menu, and
C is used for Copy. t is the value suggested by the OSF/Motif Style Guide.
6.

Set the following attributes for editCopy under pulldownMenu1:
Resource

Value

Location

Ctrl<key>C

App

acceleratorText

Ctrl+C

App

labelString

Copy

App

mnemonic

C

App

accelerator

7.

Set the following attributes for editPaste under pulldownMenu1:
Resource
accelerator

8.

Value

Location

Ctrl<key>P

App

acceleratorText

Ctrl+P

App

labelString

Paste

App

mnemonic

P

App

Set the following attributes for editDelete under pulldownMenu1:
Resource

Value

Location

labelString

Delete

App

mnemonic

D

App
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Note: There is no accelerator for the Delete function, since that would make a potentially
damaging action too easy.
Status Check

The upper portion of your user interface should look like the sample below. You should
compare your object instance hierarchy displayed in the Browser to the sample below. If
they match, save your work and proceed!

Structure of User Interface after setting resources for the Edit Menu
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Adding the Help Menu
The Help menu includes only a single PushButton. To add these elements, use the
following steps:
1.

Add an XmPulldownMenu to the interface by dragging it to the menuBar using
MB2. Three objectscascadeButton, pulldownMenu2, and
pushButtonappear on the Browser tree under menuBar.

2.
3.

Select cascadeButton in the Browser (if not already selected).
In the Resource Editor window, click on the text cascadeButton to the right of
the label Instance Name
Type the new name helpPane.
Click on the check mark at the end of the text field, or press Return.

4.
5.
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Setting Help
Button
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6.
7.

Select menuBar in the Browser.
Use the Find function of the Resource Editor to find the resource
menuHelpWidget. Enter helpPane as the resource value.
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Note: The help menu shifts to the far right edge of the Menu Bar.

Now you use the Resource Editor to add labels to the Help menu. To label the Help menu
header, perform the following steps:

Labeling Help Menu Compents
1.
2.

Select helpPane in the Browser.
Change the following resources:
Resource Value Location

3.

labelString

Help

App

mnemonic

H

App

Change the following resources for pushButton:
Resource Value Location
labelString About

App

mnemonic

App

A
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The basic interface is now complete and should appear like the figure below. If it does,
now would be a good time to save your work.
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Creating Dialogs
To complete the interface, you will now add three dialog boxes: for File Open, Edit New
Entry, and Edit Modify Entry.
Adding a file
selection box

Motif provides a number of standard dialog widgets. For File Open, you will use a
FileSelectionBox.
1.
2.
3.

Select Keep Parent by clicking on the View menu in the Main Window.
Select mainWindow in the Browser with MB1.
On the Palette, click (and release!) on the XmFileSelectionBox with MB1. If it is
grayed-out, then you do not have mainWindow selected.

4.
5.

Move the outline of the XmFileSelectionBox to your user interface.
Drop the XmFileSelectionBox anywhere on your user interface using Ctrl/MB3.

Note: Understand that you are using a two button mouse combination here. You click and
release on the XmFileSelectionBox with MB1 and then move the outline over your user
interface. Then you use the Ctrl/MB3 combination to drop it onto your user interface.
The XmFileSelectionBox is named fileSelectionBox in the Browser tree. Using
Ctrl/MB3 instead of MB1 to drop the object on the interface automatically sets it for
Natural Size, and creates a dialogShell as well. You can only use this technique
to drag an object to the actual interface, not to the Browser tree (as you can with MB2).
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The fileSelectionBox becomes the child of the object where you dropped it. It
overlaps the parent by default.
Warning: If you have not set Keep Parent and are not quite accurate in where you drop
the fileSelectionBox, it might be created as an unparented dialogShell. Since
it is not part of the main hierarchy tree, changes you make to the main tree, such as style
changes, will not propagate automatically to the dialogShell.

Hiding an Object

To hide fileSelectionBox, perform the following:
1.
2.

Select the fileSelectionBox.
Select Hide on the Resource Editor Component menu.
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Note: Hiding a user interface component performs two important functions. First it clears
up screen clutter and allows you to focus on particular portions of the user interface.
Second, when you generate code, hidden user interface components (typically dialog
boxes) are created, but not managed. This means that they will not be visible to the user
of your application until your code specifically manages them.

Adding a
Message Box
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To add an About dialog for the Help menu, perform the following steps:
1.
2.

Confirm that Keep Parent is still selected as in the prior section.
Select mainWindow in the Browser with MB1.

3.
4.
5.

On the Palette, click (and release) on XmMessageBox with MB1.
Move the outline of the XmMessageBox to the interface.
Drop the XmMessageBox anywhere on your user interface using the Ctrl/MB3
combination as in the previous section. The XmMessageBox is named
messageBox in the Browser tree.
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6.

4

Compare your widget hierarchy with the following figure to confirm that the
XmMessageBox was properly parented.
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Viewing
Compound
Children
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The MessageBox is a compound object, consisting of a number of smaller objects. To
view the makeup of the Message Box, select Show Compound Children on the Main
Window View menu. The Browser tree now displays the children of all compound objects
in the interface.

Note: Children of a compound object are indicated by a red arrow on the Browser tree.
Builder Xcessory allows only limited modification of these children.
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Unused buttons

4

By default, the MessageBox contains three PushButtons labeled: OK, Cancel, and Help.
For the About dialog, only the OK button is required, so you should delete the others as
follows:
1.
2.

Select messageBox.Cancel on the Browser.
Select Hide on the Resource Editor Component menu. The Cancel button
disappears from the display and will not be included when you generate code.

3.
4.

Repeat steps 12 for messageBox.Help.
To conceal the compound children, deselect Show Compound Children on the Main
Window View menu.

ICS TUTORIALS

25

4

Labeling the About
Box
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To add text to the about box, set the following attributes:
1.
2.
3.
4.

5.
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Select messageBox in the Browser.
In the Resource Editor window, click on the text messageBox to the right of the
label Instance Name
Type the new name aboutBox.
Set the remaining resources for aboutBox according to the table below.
(Remember to set the resource placements to App!).
Resource

Value

dialogTitle

Help About

Location
App

messageString Address Book 1.0

App

okLabelString

App

OK

Select AboutBox in the Browser
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The aboutBox should be like the figure above

6.
Customizing a
Dialog

Select Hide on the Resource Editor Component menu

You can customize the standard dialog boxes to create dialogs specific to your
application.
To create a customized dialog box, perform the following steps:
1.
2.

Click on XmMessageBox in the Palette with MB1.
Use Ctrl/MB3 to place the XmMessageBox in the interface. (Remember to make sure
Keep Parent is selected and that you have mainWindow selected in the Browser!)
This MessageBox is named messageBox on the Browser tree.

Note: Since this is the second MessageBox you have added, it would normally be named
messageBox1. However, you have already renamed the first MessageBox to
aboutBox.
3.
4.

Select messageBox if it is not already selected.
Set the Instance Name to entryBox in the Resource Editor.
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5.
6.

Set the dialogType to XmDIALOG_TEMPLATE.
Set storage location to Code (not App!).

By default, the XmMessageBox contains three PushButtons labeled: OK, Cancel, and
Help. When you reset the dialogType resource, those buttons disappear, and the
dialog is blank.
You will now create a dialog box for making an address book entry. To add the necessary
text entry fields, perform the following steps:
1.
2.
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Select entryBox (keep focus)
Place an XmRowColumn in entryBox.
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3.
4.

4

Place an XmFrame in rowColumn.
Add an XmLabel to frame.

Note: Because frame is so small in the interface, it is easier and more reliable to add the
XmLabel on the Browser, or by setting Keep Parent on frame.
4.

Set the following resources for label:
Resource
childHorizontalSpacing
childType

Value

Location

0

Code

XmFRAME_TITLE_CHILD

Code

childVerticalAlignment XmALIGNMENT_WIDGET_BOTTOM

5.
6.

Code

Add an XmTextField to frame.
Set the following resources for textField:
Resource
childHorizontalSpacing
childType

Value

Location

0

Code

XmFRAME_WORKAREA_CHILD

Code

childVerticalAlignment XmALIGNMENT_WIDGET_BOTTOM

Code
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At this point, your user interface and widget hierarchy should look like the examples
below. If they do, now would be a good time to save your work.
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Copying an object

The following is best done using the Browser:

Adding a
second frame

1.
2.
3.
4.

4

Place a second XmFrame (frame1) on the rowColumn in the interface.
Copy label into frame1. Select label with Ctrl/MB2, drag it to frame1. The
Ctrl modifier causes Builder Xcessory to make a copy rather than reparent the object.
Add an XmScrolledText to frame1.
Add two more XmFrames to rowColumn by copying frame twice.

Select Ctrl/MB2, and drag it to rowColumn. This retains all the constraints and
resources of frame and its children.
Since the last two items have the same structure as the address entry area
(entryFrame), you can reuse the work you did to format that one.

Your user interface and
widget hierarchy should
look like this
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Note: You may have to use your window manager to adjust the size of the Entry Editor to
achieve the layout in the previous illustration

Labeling the Entry
Editor Dialog

Label the four entry areas in the address Entry Editor by using an extended editor, as
follows:

Using extended
editor

Note: Using an extended editor allows you to set a resource in several objects without
updating the Resource Editor.
1.
2.
3.
4.
5.
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Select label in the Browser.
Open the extended editor for the labelString resource.
Enter the label Name. Click on the entry area, and then type in Name to replace the
previous data (in this case the default text label).
Select the App resource placement option.
Click on Apply. Leave the extended editor open.
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6.

Repeat steps 15 to set the labelString resource for the following objects:
Object
label4
label5
label6

7.
Adding Control
Buttons

4

labelString Location
Address
App
Phone
App
E-Mail
App

Dismiss the extended editor.

To add control buttons to the address Entry Editor dialog, perform the following steps:
1.
2.
3.
4.

Select entryBox in the Browser.
In the Resource Editor window, click on the text entryBox to the right of the label
Instance Name
Type the new name entryEditor.
Modify the following resources:
Resource

Value Location

cancelLabelString Cancel

App

okLabelString

App

OK

Note: Entering text in the cancelLabelString and okLabelString resources
automatically adds the respective buttons to the interface.

Final Formatting of
Entry Editor
Changing Entry
Editor title

Adjusting Entry
Editor Layout

To change the title of the Entry Editor, perform the following steps:
1.
2.

Select entryEditor in the Browser.
Set the dialogTitle resource to Entry Editor, with App resource
placement.

To do final adjustment of the layout of the address entry editor, perform the following
steps:
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1.
2.

Select entryEditor and all its children in the Browser by clicking on
entryEditor with Shift/MB1. This selects the immediate item and all its children.
Select Natural Size on the Main Window Edit menu. This allows all the items in the
address entry editor to fit together smoothly.

Hint: If you are resizing a large number of objects, it can be quicker to hide the objects
before you do the resizing, since Builder Xcessory does not have to modify the screen for
each change. To hide a group of objects, click on the folder icon by the parent object in
the Browser tree.

The address Entry Editor should now appear like the following figure:
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Saving the Interface
Select Save from the File menu in the Main Window, then click OK.
This writes out the file uil.uil, which can be read back into Builder Xcessory to
reconstruct the collection. You can also rename the UIL file at this point, for example, to
tutorial_4.uil.
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Summary
You have now completed Tutorial Four. In this tutorial, you have:
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Added a menu to your interface
Added items to a menu
Labeled menu items
Created mnemonics for menu items
Used Keep Parent to add multiple children to a widget
Added a dialog to your interface
Customized a standard dialog box
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