Procedure Manager

Allows you to define, view, and manipulate procedures available in your interface. Select Procedures from the Browser Manager menu to display the Procedure Manager:

Procedure Manager

The Procedure Manager displays the procedure name, parameter type, and procedure type of every procedure defined for your interface. The procedure name is preceded by a lock symbol if the procedure is pre-defined. Callback routines are referenced from the Callback Editor; creation routines from the Creation Routine dialog.

By default, the Procedure Manager displays all of the Builder Xcessory pre-defined callbacks. These callbacks are designated on the Procedure Manager by a lock icon, since they cannot be deleted from Builder Xcessory.

When you specify a procedure, parameter, or type in the Callback Editor or Creation Routine dialog, Builder Xcessory adds it to the Procedure Manager.

Procedure Manager File Menu

Select File from the Procedure Manager menu bar to display the Procedure Manager File menu:

Procedure Manager File Menu


Allows you to dismiss the Procedure Manager.

Procedure Manager Edit Menu

Select Edit from the Procedure Manager menu bar to display the Procedure Manager Edit menu:

Procedure Manager Edit Menu

The following sections describe the options available from the Procedure Manager Edit menu.


Cuts the currently selected procedure and places it in the procedure buffer. You cannot Cut a procedure referenced in your interface.


Copies the currently selected procedure to the procedure buffer.


Allows you to paste the contents of the procedure buffer.

Create Procedure

Adds a procedure. The default procedure name is procedure, the default parameter type is Integer, and the default procedure type is Callback.

Edit Procedure

Displays the Procedure Editor for the currently selected procedure.

Procedure Editor

Select Edit Procedure from the Procedure Manger Edit menu to display the Procedure Editor:

Procedure Editor

Procedure Name

Specify the name of the procedure in the Procedure Name text field.

Parameter Type

Specify whether the Parameter Type is Predefined or User Defined using the radio boxes to the right of the Type label.

· Predefined

Defined by default when Builder Xcessory starts up. Their UIL and C/C++ equivalents are listed in the Type Manager, and appear "locked" so that they may not be cut.

· User Defined

Appear unlocked in the Type Manager. A new type may be declared in the Procedure Editor by selecting the User Defined radio box and entering the new type in the Parameter Type text field. Builder Xcessory prompts you for confirmation and adds the new type to the Type Manager.

If the type is Undeclared, Builder Xcessory allows the user to declare the procedure parameter to be either no parameter or a parameter of any type. Otherwise, Builder Xcessory checks that the parameter passed to the procedure call is of the correct type. If the parameter type is None, Builder Xcessory will not allow the user to specify a procedure parameter when the procedure is added to a callback list or used in the Creation Routine editor. Refer to Creation Routine for more detailed information.

When you click the arrow button to the right of the Parameter Type text field, you view all types which are either predefined or user-defined (depending on the toggle setting).

Predefined types

The following table lists predefined types:

Asciz Table


Single Float


Font List




String Table

Color Table

Integer Table

Translation Table

Compound String






C data types

Equivalent C data types are listed in the Type Manager.

User Defined types

User Defined types are all other types which you have specified in the Type Manager, Procedure Manager, Callback Editor, or Creation Routine dialog.

Procedure Type

Set the Procedure Type as either Creation Routine or Callback. Creation Routine procedures may be referenced in the Creation Routine dialog. Callback procedures may be used in callback lists which are assigned as callback resource values.

A procedure's Parameter Type and Procedure Type fields may not be changed if the procedure's Reference Count is greater than zero. To decrement the count to zero, remove all references to the procedure from the current interface.

Reference Count

The Reference Count enumerates the number of times the procedure is referenced in the current interface.

Output File Option Menu

The Output File Option Menu allows you to specify the file to which the procedure will be written when Builder Xcessory generates UIL. See File Placement for more detailed information.